[cakePHP] PHP5.3にしたらDeprecatedが表示されまくったでござる

ちょっとMacBookのHDDの調子が悪くなってきたので一旦OSから再インストールして環境を再構築したのですが、PHP5.3にするとcakePHP1.2だとDeprecatedがでまくりでかなり鬱陶しい事になってしまいました。

php.iniを書き換えたり、cakePHPのソースを書き換えたりする方法は何となくイヤだったので、.htaccessで対応することにしました。

適当にcakePHPのルートの.htaccessに以下を追記すればおkでした

php_value error_reporting 22527

 iTunes Store(Japan)
 iTunes Store(Japan)
 iTunes Store(Japan)
 iTunes Store(Japan)
 iTunes Store(Japan)
Filed under: cakePHP,PHP,Programming — maesan 12:26 PM